yukimemo

大学生の進捗履歴

セキュリティ・キャンプ全国大会2018に参加します

ご報告

皆様ごきげん麗しゅう.

何かどうにも人生, 変なところで運を使ってしまうようで, タイトルの通りになりました. もっと他のところで幸せが欲しい.

続きを読む

Darknet(YOLO)をOpenCV=1で動かしたい

タイトルの通りです.

DarknetにはOpenCVオプションがありますが, これに対応しているOpenCVは3.4.0までのようです.

助けてもらいました↓ c++ - OpenCV 4.x+ requires enabled C++11 support compilation darknet fatal error - Stack Overflow

どこかの誰かさんは色々なものに手を出した結果, OpenCVをn回入れなおしているので本当に気をつけましょう. (自戒) 本当にめんどうです.

以下, 注意2点の備忘録です. * 現在(2018年5月23日) Darknetのコンパイルオプションに対応しているOpenCVは3.4.0(安定版)まで * OpenCVのcmakeの際にオプションとして -D ENABLE_CXX11=1を付加する.

自分の場合, 次のようにcmakeを実行しました.

*/opencv-3.4.0/build$ cmake -D CMAKE_BUILD_TYPE=Release -D CMAKE_INSTALL_PREFIX=/usr/local -D ENABLE_CXX11=1 ..

OpenCVの入れ直し

入れたOpenCVで某を動かしたくなったのですが, 安定版3.4.1が対応しておらず虚無になったので入れ直しました. 対応バージョンはちゃんと調べましょう.(自戒).

続きを読む

OpenCV (安定版)を入れてみた

新しいPCにOpenCVをインストールしたときのメモです.

公式ページを参考にしました. OpenCV: Installation in Linux

環境とか

OS: Ubuntu 16.04.4 LTS

入れるもの: OpenCV 3.4.1 (Stable)

続きを読む